多测师是一家拥有先进的教学理念,强大的师资团队,业内好评甚多的接口自动化测试培训机构!

18529529812

联系电话

您现在所在位置:接口自动化测试培训 > 新闻资讯

Selenium调用高版本浏览器异常问题-自动化测试

更新时间:2022-04-21 09:03:12 作者:多测师 浏览:23

  一、概述

  我之前用过selenium 2.x版本操作老版本的firefox,很流畅。现在浏览器和selenium都升级后问题随之而来。

  1.版本可能在调试调用高版本浏览器会出现系统提示报错,在排除代码错误的前提,可能是跟selenium版本与目标调用浏览器版本不兼容。

  版本则一定会出现,官方提示了最新版本的selenium调用浏览器,需要到指定网站下载一个类似“补丁文件”的东东(比如,selenium调用Firefox高版本的geckodriver文件)

  2.系统中的浏览器可能存在你不留意的更新升级,而且主流浏览器对selenium的控制现已普遍要用浏览器官方提供的控件补丁,才能正常调用操作浏览器。

Selenium调用高版本浏览器异常问题-自动化测试

  二、问题场景复原

  工作环境

  1.Ubantu 14.04版本

  2.Python 2.7 (本问题和python版本无关)

  3.没有提前下载浏览器对selenium的对应补丁文件时候

  4.selenium调用本地Firefox浏览器或者Chrome浏览器(其他主流浏览器高版本同样可能出错)

  代码

  #coding:utf-8

  from selenium import webdriver

  ‘’‘ 这是一段selenium代码’‘’

  browser = webdriver.Firefox()

  browser.get("http://docs.seleniumhq.org/")

  browser.close()

  如果你调用的是Chrome浏览器,我们换成调用Chrome浏览器方法

  browser = webdriver.Chrome()

  注意:代码没有错误,错误的是selenium与高版本浏览器不兼容

  报错信息

  调用Firfox浏览器方法报错

  调用Chrome浏览器方法报错

  报错解读

  1 对于调用Firefox浏览器,系统提示我们,缺少一个叫geckodriver的文件,并且需要设置路径指向

  2 对于调用Chrome浏览器,系统提示我们,缺少一个叫chromedriver的文件,并且需要设置路径指向

  三、解决办法

  Step1.你需要从selenium官网的提供网址针对不通浏览器下载这类补丁文件(每个主流浏览器的补丁文件都不相同)

  官方提供浏览器driver补丁文件下载地址:

  selenium提供浏览器官方driver补丁文件下载.

  Step2.把下载后的压缩包,解压缩后的文件,放在浏览器文件夹下,并且在终端命令行下配置环境变量

  1.我把调用Firefox浏览器的补丁文件geckodriver文件解压缩后放在我本地的Firefox文件夹下

  2.对照geckodriver所在位置,我在终端执行一条指令进行配置路径:

  #export PATH=$PATH:/usr/lib/firefox

  注意:我们配置环境变量指向的是浏览器补丁文件所在浏览器文件的位置,且不能指向这个文件。

  3.关于Windows环境下,MacOS环境下,都需各位少侠们自己配置其相同原理的环境变量的操作,才能有效。

  以上内容为大家介绍了自动化测试中的Selenium调用高版本浏览器异常问题,本文由多测师亲自撰写,希望对大家有所帮助。了解更多自动化测试相关知识:https://www.aichudan.com/xwzx/

联系电话

18529529812

返回顶部